TECH Car Audio Problem: AM Good FM Bad

Revad

Well-Known Member
Jan 4, 2007
1,880
Saint Louis West County
Hey fellas, I just got a mercury sable with the stock radio in it. AM works perfect, however when I change to FM the sound is horrible, just massively distorted. It did work once and sounded fine for about 45 secs, but then went back to being distorted again. Any ideas what is going on?
 
Last edited:
TS
TS
Revad

Revad

Well-Known Member
Jan 4, 2007
1,880
Saint Louis West County
Thanks, I thought it may be the antenna, but the reception is fine. If you hit the seek button it will find all the FM stations with no problem, they just sound terrible. By terrible I don't mean full of static like bad reception, but just incredibly horrible sound quality.

I'll pull it out tomorrow afternoon though and see if any of the connections are loose. Thanks again
 

kwhitelaw

OT Supporter
Sep 1, 2004
41,635
virginia
if its got the big oval radio or the generation right after that, the antenna connection is in the trunk, left side. no connection behind the deck.
 

Users who are viewing this thread

About Us

  • Please do not post anything that violates any Local, State, Federal or International Laws. Your privacy is protected. You have the right to be forgotten. Site funded by advertising, link monetization and member support.
OT v15.8.1 Copyright © 2000-2022 Offtopic.com
Served by fu.offtopic.com

Online statistics

Members online
210
Guests online
22
Total visitors
232

Forum statistics

Threads
369,479
Messages
16,886,908
Members
86,873
Latest member
vitalesan