ART Having MiniTT1 issues, any advice OTAP?

Nullius

New Member
Jun 20, 2005
8,246
Maranda
For some reason my MiniTT1 is acting like it has a dead battery, but I know the battery is not the issue. Details:

Worked fine last I used it, pulled it out of my bag to use it the other night and it wouldn't turn on - no lights, no blinky, won't pop flash remote or in its own shoe, nothing.

Went to Adorama and got a replacement battery, same issue.

Plugged it into the computer to see if the electronics were shot and to my amazement it works as it normally would (only while plugged into the computer). Meaning: I can change/save settings, upgrade the firmware, even restore factory settings (all of which I've done).

When I unplug it from the computer, the device is dead again. I'm stumped. Feels like an RMA situation, I'm waiting for PW customer support to get back to me but in the meantime I figure the real pros may have something else I can try.

Thanks guys.
 

Idyfohu

New Member
Oct 29, 2003
4,460
Utah
Odd...I haven't had mine long enough to have any issues, but sounds like a return situation for sure (my first thought was restore and update firmware). Let us know what PW says.
 
TS
TS
Nullius

Nullius

New Member
Jun 20, 2005
8,246
Maranda
Odd...I haven't had mine long enough to have any issues, but sounds like a return situation for sure (my first thought was restore and update firmware). Let us know what PW says.

Actually just got an email back, they're saying if its less than 3 years old return it and they'll take care of it free. Bought it in April of this year.

Pretty decent customer service actually, not telling me to confirm this or that or 9 million steps before theyll repair it. I guess ill update this later after the new part comes in.
 
TS
TS
Nullius

Nullius

New Member
Jun 20, 2005
8,246
Maranda
Went and bought a TT5 to use as a transmitter for tomorrow's shoot, then when I get my TT1 back I'll have one additional trigger. Works for me.
 

grphx

Active Member
Jul 2, 2010
1,072
Oklahoma
Do you have any issues with a flash not firing? The test button works, but when I take pics, sometimes the flash won't fire? I almost think it's because of a setting on my camera, because when I put my flashes on manual mode(to adjust power) sometimes the flash power changes like it is still using ETTL.
 
TS
TS
Nullius

Nullius

New Member
Jun 20, 2005
8,246
Maranda
Do you have any issues with a flash not firing? The test button works, but when I take pics, sometimes the flash won't fire? I almost think it's because of a setting on my camera, because when I put my flashes on manual mode(to adjust power) sometimes the flash power changes like it is still using ETTL.

This is a pocketwizard issue you're having? Beats me dude, that makes no sense to me. And no, until this unit completely died ive never had a misfire.
 

Users who are viewing this thread

About Us

  • Please do not post anything that violates any Local, State, Federal or International Laws. Your privacy is protected. You have the right to be forgotten. Site funded by advertising, link monetization and member support.
OT v15.8.1 Copyright © 2000-2022 Offtopic.com
Served by fu.offtopic.com

Online statistics

Members online
155
Guests online
68
Total visitors
223

Forum statistics

Threads
369,480
Messages
16,886,931
Members
86,873
Latest member
vitalesan