Help: Networking Linux and Win XP through Router

Discussion in 'OT Technology' started by unknown_soldier, Mar 21, 2005.

  1. I'm trying to network Fedora Core 3 and Windows XP through my Linksys router. Can anybody walk me through what I need to do? On the Win XP machine I can see the "Samba Server (Localhost)" but it won't connect. It gives the error:

    "\\Localhost is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

    You were not connected because a duplicate name exists on the network. Go to System in Control Panel to change the computer name and try again."

    The probem is the computer names are different on the computers (they WERE the same but I changed that). Can anybody help (primarily with the Linux side)?

    If I run VMWare, I can access the other WinXP computer through the router with no problem, but when in Linux, I can't get the two computers to network.
  2. Penguin Man

    Penguin Man Protect Your Digital Liberties

    Apr 27, 2002
    Likes Received:
    Edmonton, AB
    I've had that problem too, and as far as I can tell, it's a problem with Windows. It seems like it only happens sometimes, like I'll setup my computer (Linux) to be on the samba network, and when I check on my brother's machine (Windows) I can see it just fine. But then I reboot his machine, and it stops working and gives me that message. Then a couple days later it works again. Through all of this, I can samba into my machine from my dad's machine (a Mac), so I know that my end is working. It's a mystery :dunno:
  3. TV-MA

    TV-MA Guest

    do you have the workgroupname for the samba share the same as your windows workgroup? Also, how do you have access to the samba share setup? How are you authenticating ?
  4. the workgroups match.... I don't know jack about authenticating, and the samba share is set up to share without prompting for passwords
  5. R-Type

    R-Type The Bydo Empire must die!

    Aug 2, 2002
    Likes Received:
    'localhost' is a BAD idea for a netbios name because just about every ip-enabled OS uses that hostname for the L3 loopback interface, and depending on the OSes used on the network and their configurations, it could lead to various 'undefined behaviors.' Name each host something unique and that is not an internet resolvable FQDN (like Keep the workgroup field on each host the same for browsing convenience.

    Unless you've turned it off, the dhcpd service on the linksys should be on and serving 192.168.x.x addresses. Configure windows and fedora to use dhcp (pump/dhcpcd/dhclient on linux, last time I touched RH it used pump) and you should be all set. Unfortunately, I don't know fedora's layout to give you specifics on how to configure its scripts. google is your friend.

Share This Page