Power PC G3 desktop won't recognize USB devices

Discussion in 'OT Technology' started by Evo Shandor1995, Mar 26, 2006.

  1. Evo Shandor1995

    Evo Shandor1995 New Member

    Mar 14, 2006
    Likes Received:
    I've got an older Power PC G3 greybox desktop computer running OS 9.2.2. It didn't come with built-in USB ports but has a USB card (a pci1045) with two USB ports plugged into a PCI slot.

    Unfotunately, it won't recognize any USB device that I plug into it. Not a printer, not a jumpdrive, and most importantly, not the 40 gig LaCie external drive I bought for it. Since the built-in hard drive is only 6 gigs and has started to make a curious moaning sound on startup, I would REALLY like to be able to back up my system and especially all the data on it to the LaCie drive.

    When I run the Apple System Profiler, it recognizes the USB card, but it won't recognize any USB device plugged into the card, and it won't mount them, either. I've tried everything I can think of to get the thing working. I've reinstalled an update to the LaCie USB drive extensions. I've installed a USB drive extension. Nothing works.

    The fact that System Profiler shows the USB card in the PCI slot makes me thing the USB card is properly installed. But why won't it recognize anything plugged into the USB ports?

    Anybody have a similar problem, or any idea what's going on?

Share This Page