Problems with PHP and GD

Discussion in 'OT Technology' started by bleak, Sep 27, 2004.

  1. bleak

    bleak Guest

    ok, so I need PHP to support GD for a project I'm working on. I was using PHP 4.3.6 and phpinfo() said that GD was enabled, but all I got was a broken image (infamous red "x"), in IE, and an error message stating: "The image “https://domain.tld/path/to/test_img.php” cannot be displayed, because it contains errors.", in Firefox.

    This is on a work server, so I dropped the same test script on my personal server (also 4.3.6, with GD enabled) and it worked.

    So I decided to try upgrading the work server to 4.3.9. I compiled using the following configure options:

    ./configure --with-apxs=/usr/local/apache/bin/apxs --with-openssl
    --enable-bcmath --with-pic --enable-calendar --enable-ctype --with-gdbm
    --enable-dbase --with-db4 --enable-ftp --with-iconv --with-gd
    --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --with-mysql --with-xml
    --enable-trans-sid --enable-sockets --with-regex=php --enable-shared
    --with-zlib --with-mhash --with-mcrypt --with-curl --with-ldap

    (using the GD libraries that come bundled with PHP)

    The compilation (configure, make, make install) all went off without a hitch, but when I tried the test script again I got the same results.

    If anybody has any insight into this, the help would be greatly appreciated.
  2. bleak

    bleak Guest

    Problem solved. Solution: Don't use the auto_prepend directive in php.ini.

Share This Page