Should I buy this LS swapped Winnebago?

cowboyrps13

couchlock loves to lick my booty hole
OT Supporter
Aug 4, 2002
27,990
NC
Awesome!

Fully enjoying this thread. I ls swapped my truck and have fallen in line with ls everything. Lol.
 
  • Like
Reactions: skeletor25rs
TS
TS
skeletor25rs

skeletor25rs

It feels like real butter
Jan 26, 2001
29,822
NBTX
You have to pass smog in Texas?!:eek4:
No. I passed inspection, but they put the wrong information in the wrong spots so I had to go back and get it fixed. Then I put the wrong weight in, and had to go get it weighed. It’s only 8,000lbs.
 

James May

Well-Known Member
Jun 14, 2006
5,644
480 AZ
Since it’s overheated everytime I’ve driven it, I moved the radiator back and down to where it needed to be. It was kind of a bitch, but I took a sick day and got it done today. Test drove it a little while ago and it went great.

Before:
View attachment 247834

After:
View attachment 247835


I'd think about putting a panel/air dam over the radiator to meet the housing at the top. Forcing air through the radiator, keep the fan from pulling hot air back through at stops/traffic.
 
  • Like
Reactions: skeletor25rs
TS
TS
skeletor25rs

skeletor25rs

It feels like real butter
Jan 26, 2001
29,822
NBTX
I'd think about putting a panel/air dam over the radiator to meet the housing at the top. Forcing air through the radiator, keep the fan from pulling hot air back through at stops/traffic.
Good idea, I’ll try to whip something up.
 

cowboyrps13

couchlock loves to lick my booty hole
OT Supporter
Aug 4, 2002
27,990
NC
  • Like
Reactions: cjonesy22002
TS
TS
skeletor25rs

skeletor25rs

It feels like real butter
Jan 26, 2001
29,822
NBTX
Yeah.

But the truck is an 02 and made for it. It just had a v6 with issues. Not having the right ecu was the hardest part.

I was just wondering, because I think all of the codes mine is throwing are do to the two missing O2 sensors after the missing cats. Was wondering what you did.
 

cowboyrps13

couchlock loves to lick my booty hole
OT Supporter
Aug 4, 2002
27,990
NC
I was just wondering, because I think all of the codes mine is throwing are do to the two missing O2 sensors after the missing cats. Was wondering what you did.
I deactivated every code that had to do with the cats and o2 sensors with hptuners.

All were bad and the rear o2s siezed in the pipe. It wouldn't set readiness codes until I did that.

I have new cats and 02 sensors. Just haven't put them on. Might not turn the codes back on either.
 
  • Like
Reactions: 93rx7

cowboyrps13

couchlock loves to lick my booty hole
OT Supporter
Aug 4, 2002
27,990
NC
No check engine lights. Passed emissions test with no issue.

This year its old enough for safety only. I should've waited a couple months. :shrug:
 
TS
TS
skeletor25rs

skeletor25rs

It feels like real butter
Jan 26, 2001
29,822
NBTX
I deactivated every code that had to do with the cats and o2 sensors with hptuners.

All were bad and the rear o2s siezed in the pipe. It wouldn't set readiness codes until I did that.

I have new cats and 02 sensors. Just haven't put them on. Might not turn the codes back on either.
Kinda why I was asking. Trying to decide if I should buy (and learn) HP Tuners or hire it done at a local shop.
 

Users who are viewing this thread

About Us

  • Please do not post anything that violates any Local, State, Federal or International Laws. Your privacy is protected. You have the right to be forgotten. Site funded by advertising, link monetization and member support.
OT v15.12.0 Copyright © 2000-2023 Offtopic.com
Served by fx.offtopic.com

Online statistics

Members online
386
Guests online
88
Total visitors
474

Forum statistics

Threads
78,271
Messages
7,624,616
Members
87,103
Latest member
Nancy Sherman