ART What the fuck is going on? Lightroom and file permissions problems, help!

MSIGuy

om nom nom nom!
May 30, 2005
4,705
So I reformatted my Windows system drive and added a RAID array for storage, I backed up all my files, Lightroom catalog, backups, previews, and all the actual image files. I moved the catalog and previews to my SSD system drive and copied the image files from my image drive to my new RAID array.

Now when I open LR and go to open my old catalog I get the error of: "Lightroom cannot use the catalog because it is not writable and cannot be opened."

Okay, so I need to set the permissions, but every time I try and remove the "Read Only" check box on all the important folders (where the catalog is, the image files, the previews folder, etc.) it will pop up a dialog box and go through all the files but when I close the window and go back the read only box is checked...

I can't get my catalog to open, I need some photos from it tonight... Can anybody help? Has anyone else run into this? :hs:
 
TS
TS
MSIGuy

MSIGuy

om nom nom nom!
May 30, 2005
4,705
I was surprised to see so many replies, filled with hope, eased even...

Then I come in here and see this shit... lol
 

jared_IRL

OT Supporter
Feb 12, 2006
21,176
it sounds like you haven't assigned the correct permissions to the entire drive or folder that the catalogs are in, and the permissions in the parent folder are overriding the permissions you are assigning.

go to the top level of wherever you're storing the catalogs, assign ownership permissions, and tell it to replicate to all child folders.
 
TS
TS
MSIGuy

MSIGuy

om nom nom nom!
May 30, 2005
4,705
it sounds like you haven't assigned the correct permissions to the entire drive or folder that the catalogs are in, and the permissions in the parent folder are overriding the permissions you are assigning.

go to the top level of wherever you're storing the catalogs, assign ownership permissions, and tell it to replicate to all child folders.
That's what I was thinking too, but I still can't seem to get them set right.

My structure is like this: X:\Pictures\2011\MM-DD\xxxxxx.cr2

I'll uncheck read only from Pictures (and the child dir's) and it stays the same, I'll do it again (thinking it'll toggle it) and it does the same thing.

what version of windows did you install?
Win7 SP1
 

djlogik

Active Member
Apr 22, 2004
2,560
Tinley Park, IL
Try this. Right click on the parent folder, go to Properties. Select Security tab. Click on Advanced. Click on Change Permissions. Highlight your user account and make sure you have Full Control to that folder. Click on the Replace all child object permissions...box then apply/ok.
 

Cicada

Abraham $LINK’in
OT Supporter
Sep 30, 2008
177,920
SoCal
if there's a .lock file, delete it.

i dunno wtf that is/does, but google said so.
 

Cicada

Abraham $LINK’in
OT Supporter
Sep 30, 2008
177,920
SoCal
corruption can also cause this type of an issue.. hopefully it isn't that.

nage3.jpg
 
TS
TS
MSIGuy

MSIGuy

om nom nom nom!
May 30, 2005
4,705
Try this. Right click on the parent folder, go to Properties. Select Security tab. Click on Advanced. Click on Change Permissions. Highlight your user account and make sure you have Full Control to that folder. Click on the Replace all child object permissions...box then apply/ok.
I tried this... The permissions stay, but the read only still defaults back to on...

:wtc:
 

Users who are viewing this thread

About Us

  • Please do not post anything that violates any Local, State, Federal or International Laws. Your privacy is protected. You have the right to be forgotten. Site funded by advertising, link monetization and member support.
OT v15.8.1 Copyright © 2000-2022 Offtopic.com
Served by fu.offtopic.com

Online statistics

Members online
359
Guests online
54
Total visitors
413

Forum statistics

Threads
369,789
Messages
16,920,255
Members
86,876
Latest member
ddunn9448